USB Wifi adapter is sometimes dropped and undetected


#1

I have a TP-LINK TL-WN722N USB Wifi adapter which is very high quality. It offers an excellent connection. However, sometimes my computer “loses” it–meaning, it doesn’t only drop the connection, but also doesn’t even show the USB Wifi adapter as being plugged in! This happens seemingly randomly while the computer is running, and then when I reboot, the USB Wifi adapter will still not be mounted until I physically remove it and plug it back in. I have noticed no pattern at all as to when this occurs. I think it is an issue with kernel 3.13, because I have had the same issue with other distros based on Ubuntu 14.04 LTS (namely Mint 17). On Mint, a kernel upgrade seemed to solve the problem, but I switched to SuperX because of other issues with Mint. Should I upgrade the kernel, or is there a better solution?


#2

Please perform the following steps one by one:

  1. Update you system with: sudo apt-get update ; sudo apt-get dist-upgrade

  2. Download the file to your home directory: wget -c https://www.kernel.org/pub/linux/kernel/projects/backports/stable/v3.13/backports-3.13-1.tar.gz

  3. Unpack the archive: tar xvfz backports-3.13-1.tar.gz

  4. Change to that Directory: cd backports-3.13-1

  5. sudo make clean

  6. sudo make, you should receive an error and some instructions. Following these instructions to specify the driver you want to build and install by running the following command: sudo make defconfig-ath9k

  7. sudo make

  8. sudo make install

  9. echo "ath9k" | sudo tee -a /etc/modules

  10. echo "ath9k_htc" | sudo tee -a /etc/modules

  11. kdesudo kwrite /etc/rc.local

  12. Now add this line echo "148F 7601" | tee /sys/bus/usb/drivers/ath9k_htc/new_id just before exit 0 in /etc/rc.local

  13. sudo update-initramfs -k all -u

  14. sudo update-grub

Let me know if it works. I have not tested this solution myself. Based on this answer on AskUbuntu.


#3

I’ll give it a try as soon as I’m back at the office. Thanks!


#4

I tried a slightly different approach. I’ve noticed Linux kernel 3.13 has several unresolved issues with USB power management features that can cause the kernel to “lose” a connection to an external USB hard drive or a USB wifi adapter. Worse still, if you are in the middle of copying data when the “loss” (unmounting and failing to detect) of the external hard drive occurs, Dolphin doesn’t warn you of the failure: it reports that your files copying has finished! This is a pretty serious flaw, and from my reading, I think the two issues are related. I upgraded to the latest kernel (4.1.0-999) following the instructions here http://ubuntuhandbook.org/index.php/2014/08/install-upgrade-linux-kernel-3-16/ (and hunting for the latest kernel).

So far this seems to have resolved the issue. Before anyone else tries this, be sure to read up on regressions in kernel 4.1.0. It works on all of my machines that have Intel video cards, but not on my machine that has Nvidia graphics.