No sound, explored different options.


#1

As the title suggests, I have absolutely no sound on SuperX. This upsets me, as I want to be able to listen to music and participate in voice chatting on certain games.

I am also using Realtek drivers, I cannot find the appropriate ones for my OS.

Help?


#2

Try running alsamixer in the Terminal and change volume there, tell me if it works.

@sunit‌ please have a look.


#3

I just installed SuperX and have no sound at all. I tried adjustments with alsamixer but no change. - Thoughts?

jd


#4

Hello guys,

By default the Linux kernel that we use should include all Realtek drivers. However, if your card is one of those exotic types that does not detect, try this:

RealTek Driver Page, Pick the 3.0 driver.

Open terminal.

Type: “sudo su” and enter root password.

Change to the folder where you downloaded the driver (ie: “cd ~/Downloads”)

Type: “tar -xjf LinuxPkg_XXX.tar.bz2” , where XXX is the version of your downloaded driver (as sown in filename, example: “tar -xjf LinuxPkg_5.17rc13.tar.bz2”).

Type: “cd realtek-linux-audiopack-YYY” , where YYY is the version of your downloaded driver (as shown if folder name, example: “cd realtek-linux-audiopack-5.17”).

Type “tar -xjf alsa-driver-ZZZ.tar.bz2” , where ZZZ is the version corresponding to the filename (example: “tar -xjf alsa-driver-1.0.25-5.17rc13.tar.bz2”).

Type “cd alsa-driver-WWW” , where WWW is the version corresponding to the folder name (example: “cd alsa-driver-1.0.25”).

Type “./configure --with-cards=hda-intel”

Type “make”

Type “make install”

Reboot

Test the audio output. You can do this by right-clicking on you speaker icon and selecting sound preferences -> hardware -> select the desired audio output -> select the desired surround profile (ie: Analog Surround 5.1 Output + Analog Stereo Input) -> Test Speakers. During the installation the sound level can be muted, check out in the slider if it is not mute!