Is there an easy way to upgrade HPLIP drivers for my HP OJ5740 Multifunction Printer


#1

Hi, My query is regarding using the su command in terminal. I am trying to install HPLIP-3.16.5 to use my HP OJ5740 Multifunction Printer.
The printer is on my home network and is used by other PC’s on the network. I have no trouble using it with PCLinux OS, I can print, scan & fax using Xsane fine, but SuperX OS is quite difficult to set up and so far I can only use the universal CUP drivers to set up the print for simple print, no scan (SANE will not find it) or FAX (HPLIP-3.14.3
will not find it either.

I realise that HPLIP-3.16.5 does not support SuperX OS (neither is 3.14.3 supposed to either but does) but I am willing to experiment to get it going, otherwise I will revert to PCLinux OS and use that as my Linux OS.

The HP OPensource website has some installation tips (Not for SuperX OS) and I am trying to use an install sequence to install dependency Packages before installing HPLIP-3.16.5. I run into trouble with the following su command;

su -c “apt-get install --yes avahi libcups2 libcups2-devel libdbus-1_3-devel gcc-c++ ghostscript openssl libjpeg62-devel libnet-snmp10-devel glibc libtool libusb-devel make wget python-imaging dbus-python python-gobject libpython2.4-devel python python-reportlab sane-frontends libsane1-devel xsane”

It asks for the root password and when I type in the password I used for root when installing it fails. I have tried using the above command with -ujohn and -uroot at the end but the passwords still fail.

I am at a loss now, being a newcomer to Linux I am still learning the ropes, but in saying that I think the system should be friendlier.
Is there a way to login as root instead of user, should I reinstall Grace and perhaps select a longer password (currently 4 digits). Any help appreciated.
Thanks