Homerun Kicker


Having been advised of a conflict between the SuperX Applauncher and Homerun Kicker, I uninstalled the superxapplauncher package as requested. This resulted in void panel icons for both the SuperX Applauncher and Homerun Kicker. Additionally, I could not delete the SuperX Applauncher void icon that remained. I dragged it out of the panel onto the desktop where it stuck. I could neither delete it or move it further. It did however disappear after rebooting so all seemed well. On reinstalling Homerun Kicker however, all I get is a void icon as the plasma widget does not load, although it appears in the add widgets list. Any ideas how I can rectify this and have a working widget for Homerun Kicker?


Hi can you give a screenshot of the situation, upon testing here, we found the homerun-kicker is working, although the void icon for SuperX App Launcher is there (which can be fixed). You should have a situation like shown in the screenshot, if this the case I can tell you how get rid of the broken icon.

Also, double check if the homerun-kicker is correctly installed. Run the following once in the Terminal:
sudo apt-get purge superxapplauncher ; sudo apt-get install --reinstall plasma-widget-homerun-kicker


Thank you for responding. Unfortunately for some reason I cannot open your image.

I ran the command given but it makes no difference. Homerun Kicker is listed in the widgets available but trying to add it to the panel only results in a void icon and no message when trying to launch it from that. In my screenshot it is the last icon on the right.


The icon is of Homerun kicker? Because that command above will uninstall SuperX App Launcher and install Homerun kicker, that will result only missing SuperX luncher icon not homerun icon. Also you need to logout and log back in to see changes.


No joy, and I had already tried logging out and back in again. I ran the command, opened panel settings, add widgets and found Homerun Kicker in the list. I clicked to install it and the icon in the screenshot is all that appeared, and it does nothing when clicked.


I have found a simpler solution to your problem I will share shortly. But before I want you to run the following to remove both homerun and superxapp launcher: sudo apt-get purge superxapplauncher plasma-widget-homerun-kicker

and then install homerun kicker again: sudo apt-get install plasma-widget-homerun-kicker

once done, homerun, theoretically should work but you will still have a broken SuperX App Launcher icon (like I have in my screenshot above), which I will show you how to eliminate, once this is done and you report that homerun is running okay.


OK, back online with cable again now. :slight_smile:
This is what I did.
I ran the commands listed above with a reboot in between. I also checked that Homerun Kicker was no longer in the list of widgets available after running the first command. After running the second command Homerun Kicker was available to select and I installed it. Only the icon type as shown in my screenshot above loaded into the panel and nothing happens when it is clicked. Going into panel settings however and then right-clicking this icon gives a “remove this Homerun Kicker” message.


I am bit confused. What result show be is;

  1. SuperX App Launcher removed but you have a broken icon. That should be the icon that is not working.
  2. Homerun kicker is available and working normally.

Is this the result?

I am bit confused. What result show be is;
  1. SuperX App Launcher removed but you have a broken icon. That should be the icon that is not working.
  2. Homerun kicker is available and working normally.

Is this the result?

No. There was no icon left for the SuperX App launcher after it was removed. The icon in my screenshot is what appears after I install Homerun Kicker, but it does nothing.


Just discovered there is a mouse-over message generated by this icon (see screenshot)


What is happening is kinda weird. I think, our installations are not synced for some reason and that why you are still having the breakage and I am not. Can you reinstall libhomerun0 by sudo apt-get install --reinstall libhomerun0.

One thing, if you reinstall the OS (that will the last resort, and I will not recommend it now) and remove the SuperX App Launcher, and then install homerun (which should have been automatic, and we will fix the packages to make it automated), then this problem is easily solvable. But first do the above. Also let me know if any dpkg related errors pops up.


Thank you. I ran the command as requested but nothing has changed. There were no dpkg error messages.


I guess I need to have a remote desktop session, if you want me to get in you PC and do the changes for you. Or you may reinstall the OS and I tell you what to do from scratch. Whatever you prefer.


Although users and developers would wish for new releases to run 100% from the outset, this is never the case. This error could also be classified as minor, although Homerun Kicker is a popular widget and it is not really feasible that an OS reinstall be required to fix it. Unfortunately I do not have the time available for this at the moment and I never enable remote desktop for security reasons. I hope you are able to iron this out via the system updates for other users and new installations. In the meantime I can live with the system as it is because I still have the standard launcher and Lancelot installed and working correctly. Thank you though for taking the time to look at this.


Well I appreciate your kind words, I will sure fix it as soon as possible, and will email you if a solution is found :slight_smile:


Hi - you mention telling how to remove the rogue SuperX menu - icon - yes please… I have homerun Kicker installed and working ok… but need to now remove the X for superX menu - which is now showing on my desktop ? it appears I inadvertently moved it there whilst trying to remove it from the panel